Skip to content

Support setting SSL mode (TLS version) for Microsoft SQL Server connections #225

Description

@jelenv

It looks like SSL mode config is not supported for MS SQL Server connections. When connecting to any DB with TLS enabled, for example in Azure, where TLS is required to be 1.2 or newer, the connection fails with the following error message:

Error: Adaptive Server connection failed
(server URL)
Msg: Reason: Login failed due to client TLS version being less than minimal TLS version allowed by the server.

Table Plus version: 1.2.4 (260)
OS: Ubuntu 24.10 x64

I have tried to configure the ssl mode in ~/.tableplus/settings/connections.json, by default it's "ssl-mode": -1,, however it always resets back to -1 (probably because other values are not implemented).

Is there some way how can I connect to DBs with TLS 1.2+ on Linux?
If not, please consider this feature for implementation.

If anyone else wants it too, please give this a thumbs up.

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions